Important Note on the “ITMS-90809: Deprecated API Usage” Error

Posted: July 15th, 2020Author:

Recently, many of our users have started receiving the “ITMS-90809: Deprecated API Usage” message when submitting their Appery.io projects to AppStore. This is connected with the fact that Apple is currently in the process of formal deprecating UIWebView and is migrating to WKWebView, UIWebView’s successor.

In this connection, we would like to update our users with the following instructions on how to avoid the issue with Apple submissions:

The workaround to apply for Ionic 4 apps:

  1. Set the following Cordova versions under the App settings > Android binary/iOS binary tabs:

      

 

2.  Check if the default InAppBrowser 4.0.0 is enabled on the Core Cordova plugins tab:

      

Rebuild your app.

The workaround to apply for JQM or Ionic 1 apps:

  1. Under the Project > App Settings > Resources tab, select the latest Appery.io library version available:

 

 

2. Under the Project > App Settings > iOS Binary tab, select the latest Cordova iOS version available (6.0.0.): 

 

 

 

 

3. Under the Project > App Settings > Core Cordova plugins tab, enable WKWebviewEngineAllowFileAccessPlugin:

 

 

 

 

4. Check that you don’t have edited files on the Source tab

Then, scroll down to locate the Appery.io cordova-plugin-ionic-webview plugin and enable it:

 

Cordova WKWebView Engine and Cordova-plugin-ionic-webview plugin plugins may be unchecked if Cordova iOS 6.0.0. is selected.

Important note: please be informed, that this workaround might not work if your app is older that one year.

For the apps built earlier, switching to a different browser engine might be needed which might result in some other issues that should be considered separately in every particular case.

Also, we would like to remind you that you are always welcome to contact us if you have further questions about this or any other Appery.io related issue.