Turning Off Support for SSLv3 – POODLE Security Vulnerability

Posted: October 17th, 2014Author:

As you probably know, a new attack called POODLE security vulnerability breaks SSLv3 secure browsing. To protect your information from being intercepted, spied upon or modified by attackers in between you and the service provider, we have stopped using the unsecured SSLv3 protocol and now only use the more secured TLS protocol.